IT Infrastructure

BIS2001 IT Infrastructure and Networking

Don't use plagiarized sources. Get Your Custom Essay on
IT Infrastructure
Just from $13/Page
Order Essay

Lab week 10: Configure Switch Port Security

Learning Objectives

Upon completion of this lab, you will be able to:

· Cable a network according to the Topology Diagram.

· Configure port security

· Verify port security

In this lab activity, you will configure and verify port security on a switch. Port security allows you to restrict a port’s ingress traffic by limiting the MAC addresses that are allowed to send traffic into the port.

Topology Diagram

Addressing Table

Device

Interface

IP Address

Subnet Mask

S1

VLAN 1

10.10.10.2

255.255.255.0

PC1

NIC

10.10.10.10

255.255.255.0

PC2

NIC

10.10.10.11

255.255.255.0

Rogue Laptop

NIC

10.10.10.12

255.255.255.0

Scenario
In this lab activity, you will create a network that is similar to the one shown in the Topology Diagram. Begin by cabling the network as shown in the Topology Diagram. You will then perform the switch port configurations required for security. Use the IP addresses that are provided in the Topology Diagram to apply an addressing scheme to the network devices. When the network configuration is complete, examine the port security to verify that the network is operating properly.

Watch the following video that guide you to configure the port security step by step.

Complete the tasks provided by Part-1 and Part-2 and provide screen shot for each task.

Part 1: Configure Port Security

Task 1: Access the command line for S1 and enable port security on Fast Ethernet ports 0/1 and 0/2.

[insert screenshot]

Task 2: Set the maximum so that only device can access the on Fast Ethernet ports 0/1 and 0/2.

[insert screenshot]

Task 3: Secure the ports so that the MAC address of the device is dynamically learned and address to the running configuration.

Task 4: Set the violations so that the Fast Ethernet ports 0/1 and 0/2 are not disabled when a violation occurs, but packets are dropped from am unknows source.

[insert screenshot]

Task 5: Disable all the remaining unused ports, Hint: use the range keyword to apply this configuration to all the ports simultaneously.

[insert screenshot]

Part 2: Verify Port Security

Task 1: From PC1, ping PC2. Verify port security is enabled and the MAC addresses of PC1 and PC2 were added to the running configuration.

[insert screenshot]

Task 3: Attach Rogue Laptop to any unused switchport and notice that the link lights are red.

[insert screenshot]

Task 4: Enable the port and verify that Rogue Laptop can pingPC1and PC2. After verification, shut down the port connected to Rogue Laptop.

[insert screenshot]

Task 5: Disconnect PC2 and connect Rogue Laptop to PC2’s port. Verify that Rogue Laptop is unable to ping PC1.

[insert screenshot]

Task 6: Display the port security violations for the port Rogue Laptop is connected to.

[insert screenshot]

Task 7: Disconnect Rouge Laptop and reconnect PC2. Verify PC2 can pingPC1.

[insert screenshot]

Task 8: Why is PC2 able to ping PC1, but the Rouge Laptop is not?

Answer:
Answer the following questions
1. Illustrate the primary goals in providing security using CIA.
Answer:

2. Discuss the function of Network Address Translation (NAT).
Answer:

3. What are the main two types of encryption techniques?
Answer:

4. Compare between Secure Sockets Layer (SSL) and IP Security Protocol (IPSec). In your opinion which one is more secure.
Answer:

Lab submission
Write your name and student ID in this lab document and submit your report during your workshop session to APIC online learning system. No submission is accepted if you didn’t attend and submit your report during the workshop session.

The lab work will contribute to your final assessment results.

You need to Submit 2 files :
· Word document which include screenshots of your work and questions answers
· Packet tracer file which include the configuration you have made

ALL SCREENSHOTS SHOULD SHOW THE TASKBAR WHICH SHOWS DATE AND TIME.
DO NOT SNIP OR TRIM SCREEN SHOTS.

References:
Cisco Network Academy, 2013
Page 1 of 2

SBM4104IT Infrastructure

LAB 8. VirtualBox

Objective:

· Familiarize students with Oracle VirtualBox

· Give students hand-on experience with creation of windows 10 virtual machine.

1. Download Disk image files

The IT department team at APIC have already downloaded disk image files and they are available at student share folder.

On the desktop open the shareholder (STUDENT Applications) the select OSI ISO -> Windows 10 .VDI file and copy Windows10 file at your document folder.

2. Start VirtualBox

You can start VirtualBox as follows:

· On a Windows host, in the standard “Programs” menu, click on the item in the “VirtualBox” group. On Vista or Windows 7, you can also type “VirtualBox” in the search box of the “Start” menu.

When you start VirtualBox for the first time, a window like the following should come up:

This window is called the “VirtualBox Manager”. On the left, you can see a pane that will later list all your virtual machines. Since you have not created any, the list is empty. A row of buttons above it allows you to create new VMs and work on existing VMs, once you have some. The pane on the right displays the properties of the virtual machine currently selected, if any. Again, since you don’t have any machines yet, the pane displays a welcome message.

3. Creating your first virtual machine

Click on the “New” button at the top of the VirtualBox Manager window. A wizard will pop up to guide you through setting up a new virtual machine (VM):

On the following pages, the wizard will ask you for the bare minimum of information that is needed to create a VM, in particular:

1. The VM name will later be shown in the VM list of the VirtualBox Manager window, and it will be used for the VM’s files on disk. Even though any name could be used, keep in mind that once you have created a few VMs, you will appreciate if you have given your VMs rather informative names; “My VM” would thus be less useful than “Windows 10 64bit”.

2. For “Operating System Type”, select the operating system that you want to install later. The supported operating systems are grouped; if you want to install something very unusual that is not listed, select “Other”. Depending on your selection, VirtualBox will enable or disable certain VM settings that your guest operating system may require. This is particularly important for 64-bit guests. It is therefore recommended to always set it to the correct value.

3. On the next page, select the memory (RAM) that VirtualBox should allocate every time the virtual machine is started. The amount of memory given here will be taken away from your host machine and presented to the guest operating system, which will report this size as the (virtual) computer’s installed RAM. You can select 2048 MB RAM size.

4. Next, you must specify a virtual hard disk for your VM.

There are many and potentially complicated ways in which VirtualBox can provide hard disk space to a VM, but the most common way is to use a large image file on your “real” hard disk, whose contents VirtualBox presents to your VM as if it were a complete hard disk. This file represents an entire hard disk then, so you can even copy it to another host and use it with another VirtualBox installation.

The wizard shows you the following window:

Here you have the following options:

· To create a new, empty virtual hard disk, press the “New” button.

· You can pick an existing disk image file.

In this lab, you will pick an existing disk image that you have downloaded it. Choose the virtual hard disk file by clicking on the small folder icon as shown below:

Then select Create.

VirtualBox supports two types of image files:

· A dynamically allocated file will only grow in size when the guest actually stores data on its virtual hard disk. It will therefore initially be small on the host hard drive and only later grow to the size specified as it is filled with data.

· A fixed-size file will immediately occupy the file specified, even if only a fraction of the virtual hard disk space is actually in use. While occupying much more space, a fixed-size file incurs less overhead and is therefore slightly faster than a dynamically allocated file.

5. After clicking on “Finish”, your new virtual machine will be created. You will then see it in the list on the left side of the Manager window, with the name you entered initially.

4. Running your virtual machine

To start a virtual machine, you have several options:

· Double-click on its entry (Windows10) in the list within the Manager window or

· select its entry (Windows10) in the list in the Manager window it and press the “Start” button at the top

Use the followings to login ( If you are physically at APIC)

username: studentlab

password: Regent55

Answer the followings:

1. What is virtualization and what are its benefits

2. List and discuss different types of virtualization.

3. What are the benefits of virtualization in the context of cloud computing?

4. What does Infrastructure-as-a-Service refer to?

5. List and discuss different types of virtualization.

3 Lab submission

Put your name and student ID in this lab document and submit by due date and time to APIC online learning system. Late submission penalties apply.

The lab work will contribute to your final assessment results with 8%

You need to Submit :

· Word document which include screenshots of your work ( step by step screenshots ) of how to use Oracle VB to install an operating system and the answers for the above questions.

ALL SCREENSHOTS SHOULD SHOW THE VM TASKBAR WHICH SHOWS DATE AND TIME.

DO NOT SNIP OR TRIM SCREEN SHOTS .

Page 1 of 2

BIS2001 IT Infrastructure and Networking

LAB week 6 : IP addresses and Dynamic Routing Protocol-RIP

Objective:

· Create account with Cisco Network Academy.

· Familiarize students with IP addresses scheme.

· Give students hand-on experience with IP address allocation.

· Configure dynamic routing protocol using RIP

In order to complete this Lab you have to create account with the Cisco Network Academy if you use Cisco Packet Tracer Student in order to allow you to use the full features of the packet tracer. This include the saving of your work more than three times. In addition, this account is also required in the process of developing your packet tracer file for your Case Study-2 assignment. Without this account you cannot save your file more than three times.

In this lab, you have to create a computer network consist of three routers and three switches and some PCs as shown in Figure 2:

Task-1: Create account (if you didn’t already create one) with the Cisco Network Academy

Follow the steps provided at the word document file provided under Week-1: “Create Account- Packet Tracer Student”

Task-2: Select the required network devices as shown below:

Figure 1: Network devices

Task-3: Add module to the routers
Add two modules to the routes (Router-1, Router -2 and Router-3):
· “HWIC-2T” that provides 2 port serial high speed WAN
· “HWIC-4ESW” that provides four switching ports

Task-2:Create the network as shown in the following diagram:

Figure 2: Network topology

Addressing Table:

Device

IP Address

Subnet Mask

Default Gateway

R1

192.168.1.1

255.255.255.0

N/A

192.168.2.1

255.255.255.0

N/A

R2

192.168.3.1

255.255.255.0

N/A

192.168.2.2

255.255.255.0

N/A

192.168.4.2

255.255.255.0

N/A

R3

192.168.5.1

255.255.255.0

N/A

192.168.4.1

255.255.255.0

N/A

PC1

192.168.1.10

255.255.255.0

192.168.1.1

PC2

192.168.3.10

255.255.255.0

192.168.3.1

PC3

192.168.5.10

255.255.255.0

192.168.5.1

Router type: Cisco router: 1841
Switch type: 2950-24

Task-3: Display the port labels on your diagram, as follows:
From the main menu, select “Options” then “Preferences” and then select “Always Show Port Labels” shown in the following figure:

Task 4: Perform Basic Configuration of Router R1

Click on router-1, then select CLI tab and write “No” for the question:
“Would you like to enter the initial configuration dialog? [yes/no]:”
and press “Enter”
Then, complete, the following steps:

Step 1: Enter privileged EXEC mode.
Router>enable
Router#

Step 2: Enter global configuration mode.
Router#configure terminal
Enter configuration commands, one per line.
Router(config)#

Step 3: Configure the router name as R1.
Router(config)#hostname R1
R1(config)#

Note:
You can write some charterers of the commands in CLI and press “Tab” key from the keyboard to complete the command for you.

Use the same steps (Step-1, 2 and 3) to configure the name for router 2 and router 3 to be R2 and R3, respectively.

Task 5: Configure the IP addresses:

Step 1: click on router-1.

Step 2: Configure the FastEthernet0/0 interface for R1.

Configure the Fa0/0 interface with the IP address 192.168.1.1/24.
R1(config)#interface fa0/0
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#no shutdown

Step 3: Configure the Se0/1/0 interface for router R1.
Configure the Serial0/1/0 interface with the IP address 192.168.2.1/24.
R1(config-if)#interface serial 0/1/0
R1(config-if)#ip address 192.168.2.1 255.255.255.0
R1(config-if)#clock rate 64000
, if it is DCE
R1(config-if)#no shutdown
R1(config-if)#

Note: The interface will be activated until the serial interface on R2 is configured and activated

Step 4: Configure the Se0/1/0 interface for router R2.
Configure the Serial0/1/0 interface with the IP address 192.168.2.2/24.
R2(config-if)#interface serial 0/1/0
R2(config-if)#ip address 192.168.2.2 255.255.255.0
R2(config-if)#clock rate 64000
, if it is DCE
R2(config-if)#no shutdown
R2(config-if)#

In the same way compete the following steps:

Step 5: Configure the Se0/1/1 interface for router R2 with the IP address 192.168.4.2 and mask 255.255.255.0
R2(config-if)#interface serial 0/1/1
R2(config-if)#ip address 192.168.4.2 255.255.255.0
R2(config-if)#clock rate 64000
, if it is DCE
R2(config-if)#no shutdown
R2(config-if)#

Step 6: Configure the FastEthernet0/0 interface for R2 with the IP address 192.168.3.1 and mask 255.255.255.0
R2(config)#interface fa0/0
R2(config-if)#ip address 192.168.3.1 255.255.255.0
R2(config-if)#no shutdown

Step 7: Configure the Se0/1/0 interface for router R3 with the IP address 192.168.4.1 and mask 255.255.255.0

R3(config-if)#interface serial 0/1/0
R3(config-if)#ip address 192.168.4.1 255.255.255.0
R3(config-if)#clock rate 64000
, if it is DCE
R3(config-if)#no shutdown
R3(config-if)#

Step 8: Configure the FastEthernet0/0 interface for R3 with the IP address 192.168.5.1 and mask 255.255.255.0
R3(config)#interface fa0/0
R3(config-if)#ip address 192.168.5.1 255.255.255.0
R3(config-if)#no shutdown

Step 9: Verify IP addressing, and interfaces, use the show IP interface brief command to verify that the IP addressing is correct and that the interfaces are active.

Task 6: Configure the IP address for Ethernet interfaces of PC1, PC2, and PC3

Step 1: Configure Ethernet interfaces of PC1, PC2, and PC3 Configure the Ethernet interfaces of PC1, PC2, and PC3 with the IP addresses and default gateways from the table under the Topology Diagram.

Select PC1, then IP Configuration, and enter IP address and subnet mask and Default Gateway as shown:

In the same way, configure Ethernet interfaces of PC2, and PC3
PC2:
IP : 192.168.3.10
Mask: 255.255.255.0
Default Gateway: 192.168.3.1
PC3:
IP : 192.168.5.10
Mask: 255.255.255.0
Default Gateway: 192.168.5.1

Task 7 : Configure RIP

(Refer to the figures below for R1, R2, and R3)
Step 1: Enable dynamic routing
To enable a dynamic routing protocol, enter global configuration mode and use the router command.
Enter router ? at the global configuration prompt to a see a list of available routing protocols on your router. To enable RIP, enter the command router rip in global configuration mode.
Router(config)#router rip
Step 2: Enter classful network addresses
Once you are in routing configuration mode, enter the classful network address
for each directly connected network
, using the network command with the following syntax:
Router(config-router)#network
Router(config-router)#network
The network command:
• Enables RIP on all interfaces that belong to this network. These interfaces will now both send and receive RIP updates.
• Advertises this network in RIP routing updates sent to other routers every 30 seconds.

Select R1

Task-8: Verification of network connecting:

Now, you should be able to ping successfully between PC1 and PC3. You also should be able to successfully ping between PC1 and PC2 as shown

3 Lab submission

Put your name and student ID in this lab document and submit your report during your workshop session to APIC online learning system. No submission is accepted if you didn’t attend and submit your report during the workshop session.

The lab work will contribute to your final assessment results with 8%

You need to Submit 2 files :
· Word document which include screenshots of your work
· Packet tracer file which include the configuration you have made
Page 1 of 2

Achiever Essays
Calculate your paper price
Pages (550 words)
Approximate price: -

Why Work with Us

Top Quality and Well-Researched Papers

We always make sure that writers follow all your instructions precisely. You can choose your academic level: high school, college/university or professional, and we will assign a writer who has a respective degree.

Professional and Experienced Academic Writers

We have a team of professional writers with experience in academic and business writing. Many are native speakers and able to perform any task for which you need help.

Free Unlimited Revisions

If you think we missed something, send your order for a free revision. You have 10 days to submit the order for review after you have received the final document. You can do this yourself after logging into your personal account or by contacting our support.

Prompt Delivery and 100% Money-Back-Guarantee

All papers are always delivered on time. In case we need more time to master your paper, we may contact you regarding the deadline extension. In case you cannot provide us with more time, a 100% refund is guaranteed.

Original & Confidential

We use several writing tools checks to ensure that all documents you receive are free from plagiarism. Our editors carefully review all quotations in the text. We also promise maximum confidentiality in all of our services.

24/7 Customer Support

Our support agents are available 24 hours a day 7 days a week and committed to providing you with the best customer experience. Get in touch whenever you need any assistance.

Try it now!

Calculate the price of your order

Total price:
$0.00

How it works?

Follow these simple steps to get your paper done

Place your order

Fill in the order form and provide all details of your assignment.

Proceed with the payment

Choose the payment system that suits you most.

Receive the final file

Once your paper is ready, we will email it to you.

Our Services

No need to work on your paper at night. Sleep tight, we will cover your back. We offer all kinds of writing services.

Essays

Essay Writing Service

No matter what kind of academic paper you need and how urgent you need it, you are welcome to choose your academic level and the type of your paper at an affordable price. We take care of all your paper needs and give a 24/7 customer care support system.

Admissions

Admission Essays & Business Writing Help

An admission essay is an essay or other written statement by a candidate, often a potential student enrolling in a college, university, or graduate school. You can be rest assurred that through our service we will write the best admission essay for you.

Reviews

Editing Support

Our academic writers and editors make the necessary changes to your paper so that it is polished. We also format your document by correctly quoting the sources and creating reference lists in the formats APA, Harvard, MLA, Chicago / Turabian.

Reviews

Revision Support

If you think your paper could be improved, you can request a review. In this case, your paper will be checked by the writer or assigned to an editor. You can use this option as many times as you see fit. This is free because we want you to be completely satisfied with the service offered.

Live Chat+1(978) 822-0999EmailWhatsApp

Order your essay today and save 20% with the discount code RESEARCH